在clone虚拟机,启动后网上不能正常启动 博客分类: liunx

问题描述:

  1. 在clone虚拟机时,网卡启异常。
  2. 报错内容及现象
    [root@c1node01 ~]# service network restart  Shutting down loopback insterface: [   OK   ]  Bringing up loopback insterface:   [   OK   ] Bringing up interface eth0:  Device eth0 does not seem to be present,delaying initialization.                    [FAILED] 

解决方法一:

  1. 将eth0的mac地址改为eth1的mac地址,同时改变其DEVICE名称为eth1,再重启网络即可。
    # mv /etc/sysconfig/network-scripts/ifcfg-eth0  /etcsysconfig/network-scripts/ifcfg-eth1

解决方法二:

  1. 删除文件70-persistent-net.rules之后,重新启动系统。
    # rm -rf /etc/udev/rules.d/70-persistent-net.rules # reboot

总结:    

只要保证/etc/sysconfig/network-scripts/ifcfg-eth0 与 /etc/udev/rules.d/70-persistent-net.rules的信息一致即可,即网卡地址与网卡编号一致,这样service network restart 就可以配置成功。

 

 


发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注

在clone虚拟机,启动后网上不能正常启动 博客分类: liunx

问题描述:

  1. 在clone虚拟机时,网卡启异常。
  2. 报错内容及现象
    [root@c1node01 ~]# service network restart  Shutting down loopback insterface: [   OK   ]  Bringing up loopback insterface:   [   OK   ] Bringing up interface eth0:  Device eth0 does not seem to be present,delaying initialization.                    [FAILED] 

解决方法一:

  1. 将eth0的mac地址改为eth1的mac地址,同时改变其DEVICE名称为eth1,再重启网络即可。
    # mv /etc/sysconfig/network-scripts/ifcfg-eth0  /etcsysconfig/network-scripts/ifcfg-eth1

解决方法二:

  1. 删除文件70-persistent-net.rules之后,重新启动系统。
    # rm -rf /etc/udev/rules.d/70-persistent-net.rules # reboot

总结:    

只要保证/etc/sysconfig/network-scripts/ifcfg-eth0 与 /etc/udev/rules.d/70-persistent-net.rules的信息一致即可,即网卡地址与网卡编号一致,这样service network restart 就可以配置成功。

 

 


发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注