多版本python下,安装pip


       前天在CentOS中安装了python2.7.12和python3.5.2,今天要为两个版本安装pip,从官方上下载了get-pip.py,使用python get-pip.py,出现错误,无法安装。通过查找原因,总算是安装上了。

      下面我来说明一下:

1、出现的问题

    1),没有zlib库

    2),没有HTTPSHander库

2、解决方法

      在安装python这两个版本前,需要安装两个库zlib-devel和openssl-devel,安装完成这两个后,再对python进行编译安装后,就可以正常安装pip了。

      总结一下,安装的过程:

1、安装库

yum install zlib-devel  openssl-devel -y

安装一下这两个开发库,如不安装就会出现python安装完成后,没有zlib和HTTPSHander库的现象。

2、安装python

./configure –prefix=/usr/local/python27

make && make install

ln -s /usr/local/python27/bin/python2.7 /usr/bin/python

python3.5.2

类似python2.7.12,略有不同,自己想想吧

3、安装pip

wget https://bootstrap.pypa.io/get-pip.py –no-check-certificate

python get-pip.py

在python3.5.2下安装pip类似于2.7,请自己想想吧,这里没不写了。

本文出自 “路漫” 博客,请务必保留此出处http://4330156.blog.51cto.com/4320156/1828980