EIGRP基本配置

上一篇我们介绍了《EIGRP概述》,本篇我们开始介绍EIGRP的基础配置。

1.拓扑

拓扑有4个路由器,3种拓扑类型:P2P、BMA(广播多路访问)和NBMA(非广播多路访问)

GNS3

3.基础配置

3.1配置好各路由器的环回口和直连接口IP地址

(略)

3.2.NBMA网络环境的配置

3.2.1.帧中继交换机的配置:

配置帧中继为动态的RARP表,帧中继交换机在收到DLCI为104的1号接口的数据时发送给DLCI为401的11接口;同理DLCI为401的数据发送给DLCI为104的1号接口。

3.2.2.帧中继接口封装配置:

R1#sh running-config interface s0/1
Building configuration…

Current configuration : 117 bytes
!
interface Serial0/1
 ip address 14.14.14.1 255.255.255.248
 encapsulation frame-relay
 serial restart-delay 0
end
R1#show frame-relay map
Serial0/1 (up): ip 14.14.14.4 dlci 104(0x68,0x1880), dynamic,
              broadcast,, status defined, active

R4#show running-config interface s0/1
Building configuration…

Current configuration : 117 bytes
!
interface Serial0/1
 ip address 14.14.14.4 255.255.255.248
 encapsulation frame-relay
 serial restart-delay 0
end

R4#show frame-relay map
Serial0/1 (up): ip 14.14.14.1 dlci 401(0x191,0x6410), dynamic,
              broadcast,, status defined, active

R4#ping 14.14.14.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 14.14.14.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 20/21/28 ms

4.配置EIGRP路由协议

4.1.R1的配置

R1(config)#router eigrp 1 //启用EIGRP进程并加入相应为1的AS(自制系统),所有路由器的AS号必须相同,如果不同邻居将无法建立。
R1(config-router)#eigrp router-id 1.1.1.1 //配置路由ID,起标示作用,标示路由条目由谁带进来的,可有可无,不影响后续配置,不像OSPF,在OSPF中如果没有配置路由ID(路由器将用最大接口IP作为路由ID)可能导致虚链路出问题。
R1(config-router)#network 12.12.12.0 0.0.0.7 //网络明细宣告法,反掩码精确匹配到29位。
R1(config-router)#network 13.13.13.13 //主类网络宣告法,如果不加反掩码,将默认用主类掩码(0.0.0.255)宣告。

我们可以验证一下:

R1#show running-config | section route
router eigrp 1
 network 12.12.12.0 0.0.0.7
 network 13.0.0.0
 auto-summary
 eigrp router-id 1.1.1.1

R1(config-router)#network 14.14.14.1 0.0.0.0  //接口明细IP宣告法,只宣告本接口。
R1(config-router)#network 1.1.0.0 0.0.255.255 /
/超网网络宣告法,凡是接口的IP地址范围在1.1.0.0网段的都会参与EIGRP的宣告。

确认已经接口宣告:

R1#show running-config | section router
router eigrp 1
 network 1.1.0.0 0.0.255.255
 network 12.12.12.0 0.0.0.7
 network 13.0.0.0
 network 14.14.14.1 0.0.0.0
 auto-summary
 eigrp router-id 1.1.1.1

查看哪些接口参与EIGRP的宣告:

R1#show ip eigrp interfaces
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/2              1        0/0        51       0/15         255           0
Se0/1              0        0/0         0       0/1            0           0
Lo1                0        0/0         0       0/1            0           0
Se0/3              0        0/0         0       0/1            0           0

4.2.R2的配置
R2(config)#router eigrp 2 // 故意把AS号配置成和R1不一样,看看能否和R1成为邻接关系!
R2(config-router)#network 12.12.12.12
R2(config-router)#network 2.2.2.2 0.0.0.0
R2(config-router)#eigrp router-id 2.2.2.2

确认接口已经宣告:

R2#show ip eigrp interfaces
IP-EIGRP interfaces for process 2
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Lo2                0        0/0         0       0/1            0           0
Se0/1              0        0/0         0       0/1            0           0

检查邻居关系:

R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 2
R2# //以上表明R2不能和R1形成邻居关系。

下面把AS好改成和R1一样:

R2(config)#router eigrp 1
R2(config-router)#eigrp router-id 2.2.2.2
R2(config-router)#network 2.2.2.2 0.0.0.0
R2(config-router)#network 12.12.12.2 0.0.0.0
R2(config-router)#
*Mar  1 03:09:04.215: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 12.12.12.1 (Serial0/1) is up: new adjacency //AS改成和R1一样后邻居关系就起来了。

R2#show ip eigrp 1  neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   12.12.12.1              Se0/1             11 00:02:23   45   405  0  12

4.3.R3的配置

R3(config)#router eigrp 1
R3(config-router)#eigrp router-id 3.3.3.3
R3(config-router)#network 0.0.0.0 255.255.255.255 //全接口宣告法,可以用省略写法:0.0.0.0。等同于0.0.0.0 255.255.255.255。

R3#show ip eig
R3#show ip eigrp nei
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   13.13.13.1              Se0/1             13 00:06:18   62   372  0  19

4.4.R4的配置

R4(config)#router eigrp 1
R4(config-router)#eigrp router-id 4.4.4.4
R4(config-router)#network 4.4.4.4 0.0.0.255
R4(config-router)#net 14.14.14.0 0.0.0.7
*Mar  1 02:14:38.467: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 14.14.14.1 (Serial0/1) is up: new adjacency


5.邻居表字段解释

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold (sec) Uptime   SRTT(ms)    RTO  Q
Cnt SeqNum    

2   14.14.14.4              Se0/1            125 00:32:09   64   576  0  3
1   13.13.13.3              Se0/3             14 00:39:29   62   372  0  3
0   12.12.12.2              Se0/2             10 00:44:39   56   336  0  3

H(Handle):跟踪邻居的编号,代表发现邻居并建立邻接的顺序,0代表最先建立的邻居依次累加最先建立的在在下面最后建立的在最上面。

Address(地址):邻居的接口IP地址

Interface(接口):通过该接口从邻居那里收到了Hello包,因此通过它可以到达邻居,也就是到邻接的出口。

Hold(保持时间):表示多长时间没有收到邻居的Hello包就认为邻居失效了的等待时间。注意新版本的Cisco IOS中,收到邻居的第一个Hello分组后,任何EIGRP分组将重置定时器。

Uptime(正常运行时间):表示我认识邻居有多久了,也就是邻居在我的存活时间。如果邻居重启的话,Uptime时间又从0开始计算。

SRTT(Smooth Round Trip Time平滑平均往返时间):该字段用来确认下面要提到的RTO(重传间隔)。SRTT表示将EIGRP分组发送到邻居以及本地路由器收到邻居对该分组的确认之间的时间。在若干次给对方发送Update后对方回复ACK的平均往返时间。该平均值反映了链路的时延。

RTO(Retransmit Time-Out重传超时):表示给对方发Update后,等待对方回复ACK的最大等待时间,如果ACK一直没有收到,本地路由器就认为Update丢了或者ACK丢了,总之没有得到对方的确认。如果链路拥塞的话,本地路由器就有可能不能及时收到ACK,那么本地路由器就有必要等待一段时间以避免误解。所以RTO表示我等你“这段”时间,如果“这段”时间ACK没有回来的话,我就给对方邻居重传。

Q Cnt(Queue Count队列计数器):我发送分组(Update,Querry,Reply),在对方回ACK之前,先排一个队列,得到ACK的包就从队列移除,没有得到ACK的包,则一直在队列中排队。该值反应的是等待发送报文的个数。正常情况下,该值的变化是先1后0,因为发一个包没有收到ACK前置1,收到ACK后置0。

Seq Unm(Sequence Number序列号):从邻居里收到的最后一个更新、查询或应答分组的序列号。

除了上面这些能到在邻居表里看到的字段,下面介绍一下没有出现在邻居表里的字段:

MFT(Multicast Follow Timer组播流计时器):在MA(多路访问)网络中,一个接口连接了多个网络(如帧中继的点到多点子接口),这种情况下就没有必要挨个给邻居发送更新了,干脆就从接口直接发送组播更新这样对端所有邻居(只要启用EIGRP)就应该都能收到了。正常情况下发送一次更新就更新了所有邻居,并都能收到所有邻居的ACK。但是,如果在发送组播更新后,等待MFT时间段后没有收到某个邻居的ACK,则对其发送单播更新(没必要再次发送组播更新,因为只有部分没有收到更新)并开启RTO计时器,如果RTO超时也没有收到ACK则继续发送第二次单播更新,反复重试16次(默认值)后还是收不到对方的ACK就down neighbor。

注:RTO(针对单播)和MFT(针对多播)都是可以改变的,根据SRTT动态计算。(具体计算公式,目前Cisco没有公开)。

RTO递增计算公式:RTO*(1+1/2),最小值200,最大5000ms(重传间时间隔越来越大直到5秒钟后一直会是每5秒钟重传一次),初始值不固定按照SRTT动态计算。

hold时间在小于80s左右时(如果按照RTO最大5000ms,重传16次计算的话,5s*16=80,实际小于80),重传次数都是16次。

重传次数取决于Hold时间,Hold时间越长,重传次数越多,如果Hold时间设置到最大65535,理论上将永久重传。


6.EIGRP建立邻接条件

  1. 是否在同一个AS内

  2. 更新源是否和本地接口在同一个子网

  3. 5个K值是否一致

  4. 验证信息是否一致

关于第一个条件,上面我已经演示过这里不再演示。

更改更新源使不在同一个子网内:

R2(config-if)#ip add 12.12.12.12 255.255.255.0 //把R2和R1连接的接口IP从29位改成24位,12.12.12.12已经超过了12.12.12.0/29的范围
R2(config-if)#
*Mar  1 02:03:50.555: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 12.12.12.1 (FastEthernet0/0) is down: address changed
*Mar  1 02:03:50.939: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 12.12.12.1 (FastEthernet0/0) is up: new adjacency
R2(config-if)#do show ip eigrp neighbor
IP-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   12.12.12.1              Fa0/0             13 00:00:12    1  5000  2  0

//*

R2 能看到R1的邻接关系,是因为此时R2的更新源也就是R1给R2发送的IP地址为12.12.12.1(不包括子网掩码)落在了R2接口下的IP地址范围 (12.12.12.0/24)下,所以R2认为R1是和它在同个子网下的,所以邻接关系能正常建立,但是属于单向邻居(此时,R2有R1的邻居但是R1 没有R2的邻居)。

*//

R1(config-router)#

*Mar  1 02:03:31.135: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 12.12.12.12 not on common subnet for FastEthernet0/0
R1(config-router)#
*Mar  1 02:03:43.215: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 12.12.12.12 not on common subnet for FastEthernet0/0
R1(config-router)#
*Mar  1 02:03:44.731: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 12.12.12.2 (FastEthernet0/0) is down: holding time expired
R1(config-router)#
*Mar  1 02:03:53.771: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 12.12.12.12 not on common subnet for FastEthernet0/0
R1(config-router)#
*Mar  1 02:04:06.555: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 12.12.12.12 not on common subnet for FastEthernet0/0
R1(config-router)#
*Mar  1 02:04:19.947: IP-EIGRP(Default-IP-Routing-Table:1): Neighbor 12.12.12.12 not on common subnet for FastEthernet0/0
R1(config-router)#do show ip eig nei
IP-EIGRP neighbors for process 1

//*

R1 看不到R2的邻接关系,是因为此时R1的更新源也就是R2给R1发送的IP地址为12.12.12.12(不包括子网掩码)没有落在R1接口下的IP地址范围 (12.12.12.0/29)下,所以R1认为R2是和它不在同个子网下的,所以邻接关系不能正常建立。

*//

修改K值,观察邻接建立状态:

R1(config-router)#metric weights 0 1 0 1 0 1 //修改R1的默认Metric值从1 0 1 0 0为1 0 1 0 1
R1(config-router)#
*Mar  1 01:23:08.487: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 12.12.12.2 (FastEthernet0/0) is down: metric changed

R2(config)#

*Mar  1 01:23:19.367: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 12.12.12.1 (FastEthernet0/0) is down: Interface Goodbye received

R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1

改回R1的默认K值

R1(config-router)#metric weights 0 1 0 1 0 0
R1(config-router)#

R2#
*Mar  1 01:26:58.423: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 12.12.12.1 (FastEthernet0/0) is up: new adjacency //邻接关系恢复

验证信息留到后面验资部分讲!

7.被动接口:Passive-Interface

R1#show ip eigrp interfaces

IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/1              1        0/0        92       0/15         415           0
Se0/2              1        0/0        83       0/15         347           0
Se0/3              1        0/0        80       0/15         279           0
Lo1                0        0/0         0       0/1            0           0

首先我们在R1查看运行EIGRP的接口一共有4个:s/1,s/2,s/3和lo1,其中loopback1口其实是没有必要发送hello报文的(和他没有直连的路由器)可以把它设置成被动接口。

R1(config-router)#passive-interface default //被动掉所有接口
R1(config-router)#
*Mar  1 00:21:14.367: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 14.14.14.4 (Serial0/1) is down: interface passive
*Mar  1 00:21:14.379: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 12.12.12.2 (Serial0/2) is down: interface passive
*Mar  1 00:21:14.387: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 13.13.13.3 (Serial0/3) is down: interface passive
R1(config-router)#

//*

从上面可以看到被动所有接口后所有EIGRP邻居都down了,因为在EIGRP中被动接口不发也不收hello报文,这一点和RIP的“只发不收”不一样。

*//

R1(config-router)#no passive-interface s0/1
*Mar  1 00:24:08.447: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 14.14.14.4 (Serial0/1) is up: new adjacency
R1(config-router)#no passive-interface s0/2
R1(config-router)#
*Mar  1 00:24:11.891: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 12.12.12.2 (Serial0/2) is up: new adjacency
R1(config-router)#no passive-interface s0/3
R1(config-router)#
*Mar  1 00:24:15.311: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 13.13.13.3 (Serial0/3) is up: new adjacency

取消3个直连接口的被动状态,3个邻居重新恢复,只有loopback1接口任处于被动状态

R1#show ip eigrp interfaces
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/1              1        0/0       628       0/15        3099           0
Se0/2              1        0/0        72       0/15         279           0
Se0/3              1        0/0        64       0/15         279           0

R1#show ip protocols

  Passive Interface(s):
    Loopback1

把一些接口设置为被动状态可以节约一些系统资源!

8.观察Hello包特点

R1#debug eigrp packets hello
EIGRP Packets debugging is on
    (HELLO)
R1#
*Mar  1 00:40:56.807: EIGRP: Sending HELLO on Serial0/3
*Mar  1 00:40:56.807:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R1#
*Mar  1 00:40:58.255: EIGRP: Received HELLO on Serial0/2 nbr 12.12.12.2
*Mar  1 00:40:58.255:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
R1#
*Mar  1 00:40:59.331: EIGRP: Sending HELLO on Serial0/2
*Mar  1 00:40:59.331:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R1#
*Mar  1 00:41:00.659: EIGRP: Received HELLO on Serial0/3 nbr 13.13.13.3
*Mar  1 00:41:00.659:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
*Mar  1 00:
41:01.207: EIGRP: Sending HELLO on Serial0/3
*Mar  1 00:41:01.207:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

上面我可以看到两次Hello包的发送间隔是5秒。我们可以用下面命令来验证:

R1#show ip eigrp interfaces detail serial 0/3
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/3              1        0/0        64       0/15         279           0
  Hello interval is 5 sec //发送间隔确实为5秒
  Next xmit serial <none>
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/12
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 4
  Retransmissions sent: 3  Out-of-sequence rcvd: 0
  Authentication mode is not set
  Use unicast

其实EIGRP的Hello报文发送间隔在不同传输介质上是不一样的:

再次附上拓扑图说明一下


R1#show ip eigrp interfaces detail
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/1              1        0/0       628       0/15        3099           0
  Hello interval is 60 sec
  Next xmit serial <none>
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 1/12
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 5
  Retransmissions sent: 2  Out-of-sequence rcvd: 1
  Authentication mode is not set
  Use unicast
Se0/2              1        0/0        72       0/15         279           0
  Hello interval is 5 sec
  Next xmit serial <none>
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 1/11
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 5
  Retransmissions sent: 1  Out-of-sequence rcvd: 1
  Authentication mode is not set
  Use unicast
Se0/3              1        0/0        64       0/15         279           0
  Hello interval is 5 sec
  Next xmit serial <none>
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 0/12
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 4
  Retransmissions sent: 3  Out-of-sequence rcvd: 0
  Authentication mode is not set
  Use unicast

从说明可以看出,P2P和MA网络中Hello报文的发送间隔为5秒,但是在帧中继网络类型中发送间隔是60秒。

所以Hello报文在不同类型的接口上其发送间隔是不一样的,下面是一些常见接口类型:

接口

Hello(s)

Hold(s)

Ethernet:以太网

5

15

SerialPPP):串行-口点对点协议

5

15

SerialHDLC):串行-口高级数据链路控制

5

15

Serial(FR P-P  SubInterface):帧中继-点到点子接口

5

15

Serial(FR  PHY):帧中继-物理接口

60

180

Serial(FR P-M  SbuInterface):帧中继-点到多点子接口

60

180

注意:如果把帧中继物理接口或者点到多点子接口(这两种接口属于多路访问接口而且带宽都比较紧缺的接口)的参考带宽修改成大于T1(1544kbps)的速率的话,那么hello报文的发送间隔也会变成5s;而Hold随之也会变成15s,下面验证一下:

R1#show interfaces s0/1
Serial0/1 is up, line protocol is up
  Hardware is M4T
  Internet address is 14.14.14.1/29
  MTU 1500 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation FRAME-RELAY, crc 16, loopback not set
参考带宽1544kbps,我们对其进行修改成大于1544的速率:

R1(config-if)#bandwidth 1545
R1(config-if)#do show ip eigrp interface detail
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/1              1        0/0       423       0/15        2047           0
  Hello interval is 5 sec
  Next xmit serial <none>
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 1/14
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 5
  Retransmissions sent: 2  Out-of-sequence rcvd: 1
  Authentication mode is not set
  Use unicast

我们可以得出这么一个总结:如果帧中继物理接口或者点对多点子接口的低速率分界线为1545,速率一旦大于或者等于1545就认为链路不属于低速链路,所以hello报文就可以按照高速链路的标准去发。

R2#debug eigrp packets hello //打开R2的Hello包debug功能
EIGRP Packets debugging is on
    (HELLO)

R1(config-router)#inter s0/2

R1(config-if)#shutdown //关闭R1和R2的直连接口以便下面观察R2的情况    

*Mar  1 00:17:46.375: EIGRP: Sending HELLO on Serial0/1
*Mar  1 00:17:46.375:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R2#
*Mar  1 00:17:51.267: EIGRP: Sending HELLO on Serial0/1
*Mar  1 00:17:51.267:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R2#
*Mar  1 00:17:56.051: EIGRP: Sending HELLO on Serial0/1
*Mar  1 00:17:56.051:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R2#
*Mar  1 00:18:00.311: EIGRP: Sending HELLO on Serial0/1
*Mar  1 00:18:00.311:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R2#
*Mar  1 00:18:01.259: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 12.12.12.1 (Serial0/1) is down: holding time expired
*Mar  1 00:18:01.947: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/1, changed state to down

在R1的端口down掉后R2经过了15秒钟收不到R1的Hello报文后(只发不收)才会认为邻居down掉了。

也就是说Hold Timer是EIGRP发现拓扑变化的最大时间。但是可以通过以下方式来更改Hello和Hold的时间:

R4(config-if)#ip hello-interval eigrp 1 10
R4(config-if)#ip hold-time eigrp 1 30
R4(config-if)#end          
R4#show ip
*Mar  1 00:40:36.043: %SYS-5-CONFIG_I: Configured from console by console
R4#show ip eigrp interfaces detail s0/1
IP-EIGRP interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/1              1        0/0        56       0/15         243           0
  Hello interval is 10 sec //修改成功,hello间隔已经变成10 sec
  Next xmit serial <none>
  Un/reliable mcasts: 0/0  Un/reliable ucasts: 13/11
  Mcast exceptions: 0  CR packets: 0  ACKs suppressed: 6
  Retransmissions sent: 1  Out-of-sequence rcvd: 2
  Authentication mode is not set
  Use unicast

R4#debug eigrp packets hello
EIGRP Packets debugging is on
    (HELLO)

R4#
*Mar  1 00:43:20.935: EIGRP: Sending HELLO on Serial0/1
*Mar  1 00:43:20.935:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R4#
*Mar  1 00:43:29.827: EIGRP: Received HELLO on Serial0/1 nbr 14.14.14.1
*Mar  1 00:43:29.827:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0 peerQ un/rely 0/0
*Mar  1 00:43:
30.187: EIGRP: Sending HELLO on Serial0/1
*Mar  1 00:43:30.187:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R4#
*Mar  1 00:43:39.711: EIGRP: Sending HELLO on Serial0/1
*Mar  1 00:43:39.711:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0
R4#
*Mar  1 00:43:48.439: EIGRP: Sending HELLO on Serial0/1
*Mar  1 00:43:48.439:   AS 1, Flags 0x0, Seq 0/0 idbQ 0/0 iidbQ un/rely 0/0

变成10 sec发送一次hello报文!

注意:

  • 通过修改EIGRP计时器有助于加快网络收敛速度。

  • 修改计时器时,两端的时间可以不一致,但是这样有可能会引起路由翻动和稳定性!

  • Hello时间的修改影响本地路由器发送间隔;Hold时间的修改影响对端保持本端邻居的时间。

本文出自 “E网情深” 博客,请务必保留此出处http://jettcai.blog.51cto.com/1447637/1659461


发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注